GTK+ Forums

Discussion forum for GTK+ and Programming. Ask questions, troubleshoot problems, view and post example code, or express your opinions.
It is currently Thu Apr 17, 2014 1:09 am

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: composited called but compositing is not supported
PostPosted: Fri Nov 02, 2012 6:57 pm 
Offline
GTK+ Guru

Joined: Fri Mar 25, 2011 5:16 pm
Posts: 176
Location: USA
When I run the alpha demo from the gtk "tests" folder it says: "Screen supports alpha" and "composited"
But when I run the "composited window" demo I get the warning:
Quote:
Gdk-WARNING **: gdk_window_set_composited called but compositing is not supported

I'm running Ubuntu Natty "not classic or classic-no-effects."
ATI Radeon HD 3200 (proprietary drivers.)
Compiz version 1:0.9.4+bzr20110415-0ubuntu2.
Gtk+-3.2.3

My graphics are listed here: https://help.ubuntu.com/community/RadeonDriver
And it says:
"Accelerated 3D support"
"All these Radeon(HD) cards and derivatives have good 3D acceleration support"

Log file here /var/log/Xorg.0.log
Contains the lines:
Quote:
[ 36.557] (II) Initializing built-in extension COMPOSITE
[ 35.940] (II) fglrx(0): Enable composite support successfully

In the compiz settings manager I have composite checked.
In gconf-editor under: apps->metacity->general I have "compositing_manager" checked.

Why isn't this working?


Top
 Profile  
 
 Post subject: Re: composited called but compositing is not supported
PostPosted: Sat Nov 03, 2012 5:22 am 
Offline
Never Seen the Sunlight

Joined: Thu Mar 24, 2011 2:10 pm
Posts: 328
Location: Sydney, Australia
If you are running demos from the repositories and getting this, then it is likely a bug and you are better reporting it to the developers.


Top
 Profile  
 
 Post subject: Re: composited called but compositing is not supported
PostPosted: Sun Nov 04, 2012 5:06 pm 
Offline
GTK+ Guru

Joined: Fri Mar 25, 2011 5:16 pm
Posts: 176
Location: USA
Thanks Paul, I just got a notice saying there won't be any more security upgrades for Ubuntu Natty so I need to upgrade anyway.
I'll probably go to Debian Wheezy and Ubuntu Quantal in a dual boot on a new system.

Thanks


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group