GTK+ Forums

Discussion forum for GTK+ and Programming. Ask questions, troubleshoot problems, view and post example code, or express your opinions.
It is currently Fri Apr 18, 2014 5:34 am

All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: gtkmm-2.4-dev JPEG library version
PostPosted: Tue Oct 29, 2013 3:44 pm 
Offline

Joined: Thu Oct 24, 2013 8:04 pm
Posts: 1
Hello,

I'm trying to load a jpeg into a pixbuf, but I get the following error, how can I solve this?

Code:
try{
        Gdk::Pixbuf::create_from_file(".../Test.jpg");
    }
    catch(const Glib::FileError& ex) {
    std::cerr << "FileError: " << ex.what() << std::endl;
    }
    catch(const Gdk::PixbufError& ex) {
    std::cerr << "PixbufError: " << ex.what() << std::endl;
    }


Quote:
PixbufError: Failed to load image 'NoDataImage.jpg': Error interpreting JPEG image file (Wrong JPEG library version: library is 62, caller expects 80)


I'm using gtkmm-2.4-dev on Ubuntu 13.10. The only install version of libjpeg is 8, so where is this error message coming from?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group