GTK+ Forums

Discussion forum for GTK+ and Programming. Ask questions, troubleshoot problems, view and post example code, or express your opinions.
It is currently Tue Sep 16, 2014 7:29 pm

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: XInput2 extension not found
PostPosted: Fri Jul 06, 2012 12:56 pm 
Offline

Joined: Fri Jul 06, 2012 11:19 am
Posts: 1
hi
when i want to install gtk ,when i enter ./configure it will say
XInput2 extension not found
is there any way i ignore this package or anywhere i install it?


Top
 Profile  
 
 Post subject: Re: XInput2 extension not found
PostPosted: Sat Jul 07, 2012 7:46 am 
Offline
Never Seen the Sunlight

Joined: Mon Apr 28, 2008 5:52 am
Posts: 745
Location: UK
Hi,

You may not have all the dependencies installed on your system to build GTK+ from source. Make sure that you have all development dependencies installed so that you can compile the sources.

You may find it easier to install GTK+ from a pre-built and packaged bundle. This will usually be a .rpm or .deb and will vary depending on which system you are using. You will normally have a package manage that can install it for you.

_________________
E.


Top
 Profile  
 
 Post subject: Re: XInput2 extension not found
PostPosted: Sat Jul 07, 2012 3:54 pm 
Offline
GTK+ Guru

Joined: Fri Mar 25, 2011 5:16 pm
Posts: 177
Location: USA
XInput version 2 is a dependency starting with gtk+-3.4.0. So I'll assume your trying to install at least gtk+-3.4.0.
The file called: "INSTALL" contains the list of dependencies. For instance gtk+-3.4.3 (newest stable version) has:
Quote:
Prerequisites
=============

GTK+ requires the following packages:

- The GLib, Pango, GdkPixbuf, ATK and cairo libraries, available at
the same location as GTK+. GTK+ 3.4.3 requires at least
GLib 2.32.0, Pango 1.30.0,
GdkPixbuf 2.26.0, ATK 2.2.0
and cairo 1.10.0.

- Each GDK backend has its own backend-specific requirements. For
the X11 backend, X11 R6 and XInput version 2 (as well as a number
of other extensions) are required.

- gobject-introspection 1.32.0 or newer.


You can download the source to check the "INSTALL" file from here and just change the 3.4 to whatever series you're using: http://ftp.gnome.org/pub/gnome/sources/gtk+/3.4/
I could advise you better if you listed what your O.S. and revision is but I just posted a rather extensive step-by-step for installation here:
http://www.gtkforums.com/viewtopic.php?f=3&t=177997


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group