GTK+ Forums

Discussion forum for GTK+ and Programming. Ask questions, troubleshoot problems, view and post example code, or express your opinions.
It is currently Tue Aug 30, 2016 3:00 pm

All times are UTC

Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Non-programming question: dconf problems
PostPosted: Thu Aug 02, 2012 11:38 pm 

Joined: Thu Aug 02, 2012 11:14 pm
Posts: 1
I'm really not sure if this counts as a Gnome or a GTK question, but I hope someone can help me here. I'm running Mageia 2. gtk versions are 2.24.10 and 3.4.1 but only GTK 3 is giving me the problem.

I normally run without Gnome (I use fvwm2 and a fairly bare .fvwm2rc and .xinitrc), but when I move away my .fvwm2rc, .xinitrc, and .Xdefaults and start X and get Gnome, I run into the same problems anyway.

I am trying to run dconf-editor. If I try to run it, no settings are editable. For instance, I can go into org/gtk/Demo and see a "color" set to "red". but if I try to pick "blue" it changes back to "red" without accepting the change. Also, the "set to default" button is greyed. The settings I am trying to change are in org/gnome/gtk/settings/file-chooser, however, the settings folder isn't even present.

If I run as root, the settings and file-chooser are present and the "set to default" button is not greyed; however, I am still unable to change any settings.

If I look at the configuration files manually, /etc/dconf/profile contains a single file "gdm" with two lines: "user" and "gdm".

/home/arromdee% ps -ef | grep gdm
gdm 6376 1 0 18:52 ? 00:00:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
gdm 6398 1 0 18:52 ? 00:00:00 /usr/lib/gvfsd
gdm 6408 1 0 18:52 ? 00:00:00 /usr/lib/gconfd-2
arromdee 8303 7379 0 19:33 pts/1 00:00:00 grep --color gdm

/etc/dconf/db/gdm.d contains an 00-upstream-settings with a few settings and a warning saying to " create your own file next to it with a higher numbered prefix, and run dconf update". I created an 01-upstream-settings which contained the extra lines


after a dconf update, "dconf dump /" (still as root) shows me that the org/gtk/settings/file-chooser are not changed at all. dconf dump / (as myself) shows nothing at all.

It appears the daemon is running.

/etc/dconf/db/gdm.d# ps -ef | grep dconf
arromdee 7127 1 0 19:08 ? 00:00:00 /usr/lib/dconf-service
root 8458 8042 0 19:37 pts/0 00:00:00 grep --color dconf

Killing the service and letting it restart makes no difference/

There is nothing in /etc/dconf/db/gdm.d/locks (there was, but I removed it and did a dconf update).

How can I get modifications to settings to work?

 Post subject: Re: Non-programming question: dconf problems
PostPosted: Sat Oct 27, 2012 7:09 am 

Joined: Sat Oct 27, 2012 6:58 am
Posts: 1
I had a similar problem, where I wasn’t able to set anything in DConf no matter what tool I used (gnome-control-center, dconf-editor, gsettings, demonic forces). I didn’t try using root, though.

What I found was that I had two files in the /etc/dconf/profile directory: “user” and “gdm”. “user” looked like this:


while “gdm” looked like this:


I changed “usr” to look like “gdm,” and suddenly DConf settings worked again (and thank God, because the lack of DConf settings was preventing me from running GNOME at all under Ubuntu 12.10).

I’m not sure how well this applies to your situation, since your “/etc/dconf/profile/gdm” looks like my “etc/dconf/profile/user”, and you have no file “/etc/dconf/profile/user”. I hope this gives you some ideas, though!


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC

Who is online

Users browsing this forum: No registered users and 3 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group