GTK+ Forums

Discussion forum for GTK+ and Programming. Ask questions, troubleshoot problems, view and post example code, or express your opinions.
It is currently Wed Apr 23, 2014 6:47 am

All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Can't compile GTK in Ubuntu...
PostPosted: Sun Jan 22, 2012 10:43 am 
Offline

Joined: Sun Jan 22, 2012 10:41 am
Posts: 1
Hi !
When I try to compile a gtk file using xterm, I write (for a program named foo.c) "gcc -c foo.c `pkg-config --cflags glib-2.0` `pkg-config --cflags gtk+-2.0` ". Is this wrong ? When I try to compile a message appears " No package glig-2.0 found ".

Thanks in advance


Top
 Profile  
 
 Post subject: Re: Can't compile GTK in Ubuntu...
PostPosted: Sun Jan 22, 2012 11:44 am 
Offline
Never Seen the Sunlight

Joined: Thu Mar 24, 2011 2:10 pm
Posts: 328
Location: Sydney, Australia
The most likely reason for this problem is that although you have gtk installed you don't have the headers. These are found in the .dev packages in which case you have to make sure you install all the *-dev packages that are part of the gtk family. Same goes whenever you compile something that links to an external library. The one that's causing you're particular error is libglib2.0-dev
If this isn't it please make sure you give us as much information as you can about your system, e.g. ubuntu version, gtk version etc.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group